Статьи

Статьи->Cisco->NAT через loopback интерфейс [ Поиск ]

NAT через loopback интерфейс
Заголовок NAT через loopback интерфейс
Описание Схема с реализацией NAT'а через loopback интерфейс Cisco
Отправил sergey
Понадобилось как-то раз мне для удаленного офиса к которому из центра прокинуто 2 канала (основной и резервный), оконеченных серыми сетями пробросить инет, и сделать так чтоб они ходили наружу с одного сорс адреса, тоесть натились в него, из-за привязки некоторых сервисов к IP-адресу.

Решил сделать нат через
Loopback интерфейс. После перечитки кучи докумментации на cisco.com , opennet.ru и других не менее известных ресурсах сети ;) сделал все-таки по-своему и оно заработало.

Итак, начну. В удаленном офисе у меня стоит Cisco 871 с иосом AdvanceEnterprise, другие версии поддерживают только 1 vlan. В центральном офисе - Cisco 2851.

192.168.1.0/255.255.255.0 - Lan в удаленном офисе;
1.1.1.254 - IP-адрес для NAT'a Lan'а удаленного офиса в Inet;
192.168.5.0/255.255.255.252 - интерфейсная пара выданная провайдером который предоставляет канал связи (у меня он выбран как основной);
192.168.5.4/255.255.255.252 - интерфейсная пара выданная провайдером который предоставляет канал связи (у меня он выбран как резервный);

Между этими кошками подымаем OSPF для того чтобы
Cisco 871 знала через какой из каналов отдавать пакеты, тоесть она получает анонс маршрута по дефолту со стороны Cisco 2851. А Cisco 2851 в свою очередь - получает информацию о том, через какой канал сейчас доступен 1.1.1.254, тоесть через какой канал посылать пакеты на этот адрес.

Вот часть конфига
Cisco 871, которая касаеться этого действа (я надеюсь понятно, что IP-адреса изменены).


interface Loopback0
 ip address 1.1.1.254 255.255.255.255
!
interface FastEthernet0
 switchport access vlan 1
!
interface FastEthernet1
 switchport access vlan 1
!
interface FastEthernet2
 
switchport access vlan 1
!
interface FastEthernet3
 switchport access vlan 2
!
interface FastEthernet4
 ip address 192.168.5.2 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 ip ospf cost 21
 duplex auto
 speed auto
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip policy route-map NAT-loopback
!
interface Vlan2
 ip address 192.168.5.6 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 ip ospf cost 22
!
router ospf 11
 router-id 1.1.1.254
 log-adjacency-changes
 redistribute connected subnets
  passive-interface default
 no passive-interface FastEthernet4
 no passive-interface Vlan2
 network 192.168.5.0 0.0.0.3 area 11
 network 192.168.5.4 0.0.0.3 area 11
 distance ospf external 2
!
ip nat inside source list NAT interface Loopback0 overload
!
ip access-list extended NAT
 permit ip 192.168.1.0 0.0.0.255 any
 deny   ip any any
!
route-map NAT-loopback permit 10
 match ip address NAT
 set interface Loopback0
!


Теперь часть конфига моего роутера Cisco 2851 находящегося в центральном офисе (часть отвечающую за маршрутизацию в Inet не привожу, там 4 BGP-сессии, думаю дальше уже ясно):

interface GigabitEthernet0/0.10
 
ip address 192.168.5.1 255.255.255.252
 ip ospf cost 21
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip mroute-cache
 no cdp enable
!
interface GigabitEthernet0/0.12
 
ip address 192.168.5.5 255.255.255.252
 ip ospf cost 22
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip mroute-cache
 no cdp enable

!
router ospf 11
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute connected subnets
  passive-interface default
 no passive-interface GigabitEthernet0/0.10
 no passive-interface
GigabitEthernet0/0.12
 network 192.168.5.0 0.0.0.3 area 11
 network 192.168.5.4 0.0.0.3 area 11
 default-information originate always
 distance ospf external 2






Вот теперь все работает.
Голосов Голосов: 4 - В среднем: 5

Добавить комментарий Оценить
Комментарии

Статистика
Всего 14 статей в базе
Наиболее просматриваемые: NAT через loopback интерфейс
Лучшие по оценкам: NAT через loopback интерфейс

Пользователи в разделе статьи: 4 (0 Пользователи 4 Гости и 0 Скрытые пользователи)
Видимые пользователи: 0


 

MKPortal ©2003-2008 mkportal.it